669676665 gmolino@gmail.com

Se han descubierto dos vulnerabilidades en WinRar versión 3.5 (y posiblemente anteriores) que pueden ser explotadas remotamente por usuarios maliciosos.

WinRar es un popular programa de compresión de archivos que soporta un largo número de formatos.

La primera vulnerabilidad se encuentra en el formateo de cadenas de errores de diagnostico, al informar de nombres de archivos incorrectos en formatos UUE/XXE. Esta circunstancia puede conllevar como resultado la ejecución de código arbitrario al decodificar un fichero de este tipo.

El segundo problema se encuentra en un desbordamiento de pila en la dll encargada de la decodificación de ficheros .ACE. Este desbordamiento puede ser conseguido mediante la introducción maliciosa de nombres de fichero suficientemente largos en un archivo, y su posterior extracción por parte de la víctima.

Se recomienda la actualización a la última versión disponible, que en estos momentos se trata de WinRar 3.51.

Via Hispasec