669676665 gmolino@gmail.com

El equipo de desarrollo de Macromedia ha informado de la existencia de un problema de seguridad en el reproductor Flash Player catalogado como altamente crítico.

Macromedia Flash Player es un popular reproductor multimedia, creado y distribuido por Macromedia, de ficheros Shockwave Flash(SWF), con soporte para numerosas plataformas: Microsoft Windows, Linux, Mac OS, Solaris, HP-UX y OS/2 entre otras.

El problema, descubierto en primera instancia por el personal de investigación de eEye Digital Security, radica en que un atacante malintencionado podría lograr, de modo remoto, la ejecución de código arbitrario, y por tanto, comprometer seriamente los equipos con versiones no actualizadas.

Cuando el navegador o aplicación lectora de Flash carga un fichero Shockwave SWF, obtiene un parámetro identificador del tipo de marco utilizado. Un error de diseño provoca que no se valide el parámetro leído, y dado que ese valor se utiliza como índice en el componente Flash.ocx para referir a una matriz de punteros, sería posible, a través de un SWF especialmente creado, hacer referencias a porciones de memoria que estén bajo el control del atacante, asumiendo Flash Player el uso de los valores suministrados por el usuario malicioso.

Las versiones afectadas confirmadas son las pertenecientes las ramas 7.x y 6.x, sin descartárse problemas en ramas anteriores. Dado que el origen del problema es el componente ActiveX Flash.ocx, sólo están afectados los sistemas Microsoft Windows, así como los sistemas clásicos Macintosh, en los que exista el citado componente.

Macromedia ha publicado una versión 8.0.22.0 que corrige el problema de seguridad. Hispasec recomienda instalar esta versión con la máxima premura. Para los sistemas donde no se soporte esta versión 8, caso de algunas versiones Macintosh clásicas así como Microsoft Windows 95 y NT, se puede instalar un parche corrector 7r61, que garantiza la estanqueidad ante ficheros SWF de origen malicioso.

Mas info

Via Hispasec