669676665 gmolino@gmail.com

Se han identificado dos vulnerabilidades en Adobe Macromedia Flash Player que pueden ser aprovechadas por atacantes para ejecutar código arbitrario o provocar una denegación de servicio.

El primer fallo se debe a un error motivado por un acceso a memoria inadecuado a la hora de interpretar ficheros en formato SWF especialmente manipulados. Esto puede ser aprovechado para ejecutar código con sólo visitar un enlace en el que se reproduzca un fichero que pretenda aprovechar esta vulnerabilidad. Al parecer sólo la versión 8.0.24.0 se ve afectada.

El segundo fallo se debe a un error no especificado a la hora de manejar ficheros SWF especialmente manipulados. Esto puede ser aprovechado por algunas páginas para que, cuando sean visitadas, provoquen que deje de responder el navegador al que el reproductor está enlazado. Las versiones 8.0.24.0 y anteriores son vulnerables.

Estas vulnerabilidades fueron descubiertas por Fortinet el 28 de noviembre de 2005 y el nueve de junio de 2006 respectivamente pero ha sido ahora, cuando Adobe Macromedia ha publicado una nueva versión, que se han hecho públicas.

Se recomienda actualizar a la versión 9.0.16.0 desde aqui o directamente desde aqui

Para conocer qué versión utiliza cada posible navegador en el sistema, se puede visitar esta página.

Via Hispasec