669676665 gmolino@gmail.com

Mozilla ha publicado una nueva actualización para Mozilla Firefox que soluciona siete problemas de seguridad. Cuatro están calificadas como críticas, dos como de moderado y una como de bajo peligro. Thunderbird y SeaMonkey también se ven afectados por las siguientes vulnerabilidades, según la clasificación MFSA (Mozilla Foundation Security Advisory).

MFSA 2006-57: Soluciona un problema de corrupción de heap a través de expresiones regulares en javascript. Es posible hacer que el motor de la expresión regular lea más allá del final de la memoria intermedia, provocando que la aplicación deje de funcionar.

MFSA 2006-58
: Soluciona un fallo por el que se podría comprometer el mecanismo de actualización automática si el usuario acepta certificados no fiables.

MFSA 2006-59: Soluciona varios fallos de concurrencia que derivaban en problemas de corrupción de memoria que podrían ser potencialmente utilizados para ejecutar código arbitrario en el sistema.

MFSA 2006-60: Falsificación de firma RSA. Los clientes Mozilla contienen algunas Autoridades Certificadoras que tienen firmas RSA de exponente 3, que se han descubierto vulnerables a un ataque de falsificación por el que firmas inválidas no serían detectadas.

MFSA 2006-61
: Soluciona una forma por la que se puede inyectar contenido dentro de un subframe de otra página utilizando
targetWindow.frames[n].document.open(). Esto haría que el contenido de un atacante pareciese legítimo en la página.

MFSA 2006-62
: Cross site scripting a través del bloqueador de ventanas emergentes. No supone una amenaza seria. La página del atacante debería encuadrarse en otra página, abrir una ventana emergente y que el usuario la abriese.

MFSA 2006-63: Afecta sólo a Thunderbird. Si un mensaje HTML que contiene una imagen remota apuntando a script XBL es abierto, un atacante podría ejecutar javascript aunque estuviese deshabilitado.

MFSA 2006-64
: Soluciona varios problemas de estabilidad que derivaban en problemas de corrupción de memoria que podrían ser potencialmente utilizados para ejecutar código arbitrario en el sistema.

Estos problemas de seguridad están solucionados en la versión 1.5.0.7 de Firefox y Thunderbird y la 1.0.5 de SeaMonkey, y pueden actualizarse desde mozilla.org o a través de las actualizaciones automáticas.

Via Hispasec